Archiv

Way to Linux

Jahrelang Windows, ohne Kontakt zur Linux-Welt - Jetzt wird es Zeit alles nachzuholen. Wer will kann hier meine Erlebnisse miterleben.

Gestartet hat es eigentlich schon vor einigen Jahren, als ich mir einfach mal die damals aktuelle Suse Linux Distri gekauft habe und die auf mein Notebook gehauen habe.

Und was soll ich sagen, der Ärger ging auch direkt los. Meine PCMCIA-Netzwerkkarte war ums verrecken nicht ans laufen zu bekommen. Eine simple Netzwerkkarte hat mich gefühlte 2 Jahre gekostet. Nun gut, es waren nur einige Abende mit Googlen, Foren durchsuchen und basteln.

Ok, als dies dann ging habe ich mir ernsthaft die Frage gestellt wie bescheuert jemand sein muss Linux im ernst zu benutzten?

Warum sollte ich tagelang in den tiefen irgendwelcher Configdateien graben, nur um ins Internet kommen zu können oder auf meinen Zweitrechner zugreifen zu können?

Nun, machen wir uns nichts vor. Solche Fragen zählen in der Realität nicht, denn Linux ist Realität und durch seine Flexibiltät sicher auch nicht ganz so bekloppt wie ich heute noch denke.

Schauen wir was noch kommt.

11.2.07 22:13, kommentieren

Neuanfang

Nachdem ich mein Suse Linux 9.0 lange in der Ecke liegen lassen hatte, habe ich mir (wieder) meine Laptop geschnappt und (wieder) Linux darauf installiert.

Natürlich erkennt auch dieses mal Yast zwar meine Netzwerkkarte, aber fühlt sich trotzdem nicht genötigt diese auch funktional zu hinterlassen. Bull-Shit. Also basteln wir los:

Diesmal bin aber viiieel schlauer. Meine Readme von damals läßt mich die Netzwerkkarte in 10 Minuten einrichten:

Mal zu allererst die Karte korrekt in "/etc/pcmcia/config" unter "Device driver devinition" eingetragen:
device "realtek_cb"
class "network" module "cb_enabler" , "realtek_cb"

Dann unter "CardBus Cards":
card "Realtek CardBus Ethernet Card"
manfid 0x0000, 0x024c
bind "realtek_cb"

Das wars? Natürlich nicht. Damit die Karte auch nach dem Reboot funktioniert, muss sie das Interface eth0 noch mit dem passendem Modul verknüpft werden. Dazu in "/etc/modules" folgendes hinzufügen:
"alias eth0 8139too"

Laut meinen Helfern im Forum muss ich noch ein "depmod" absetzten. "depmod"? Was zum Teufel? Ok, das kann ich später mal recherchieren.

Weiter gehts:

"ifconfig etho up" setzt das Interface Online, ohne geht nichts. Ok, das kenne ich von der Cisco PIX Firewall.

"lsmod" zeigt jetzt auch das Modul "8139too" an, das soll bedeuten, das ich bisher alles richtig gemacht habe. Ich glaube das mal und gönne mir etwas Zufriedenheit.

Schnell noch eine IP an das Interface:
"ifconfig eth0 192.168.0.254 netmask 255.255.255.0"

Jetzt sind wir auf der Zielgraden, schnell noch das Standardgateway auf meinen Router setzen:
"route add default gw 192.168.0.1"

Feste Nameserver kann ich wieder per Yast eingetragen, ich wüßte auch nicht wo ich das sonst tun könnte

JAAAA!!! SCHAUT HER: ICH HABE FEUER GEMACHT!!!

Öhhhm... Ich habe eine Netzwerkverbindung ins Internet (über das Standardgateway meines Routers) und zu meinem Zweitrechener (Windows).

Das Leben ist eine Pralinienschachtel...

11.2.07 22:48, kommentieren

Nachholbedarf

Ihr habt es sicher schon bemerkt, ich pflege meine Erlebnisse aus dem Gedächtnis nach. Ich beginne diesen Blog erst jetzt und ihr könnt froh sein, dass ich bei meinen ersten Linux-Versuch noch nicht hier geschrieben habe.

Soviele Schimpfworte hätten unter Garantie zum Ausschluß von myBlog geführt

11.2.07 23:04, kommentieren


Werbung